r1: [svn-inject] Installing original source of openssh-cn
authorGrupa za izradu paketa <paketi@carnet.hr>
Tue, 18 Sep 2007 14:05:53 +0000 (14:05 +0000)
committerGrupa za izradu paketa <paketi@carnet.hr>
Tue, 18 Sep 2007 14:05:53 +0000 (14:05 +0000)
README.CARNet [new file with mode: 0644]
changelog.CARNet [new file with mode: 0644]
debian/changelog [new symlink]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/postinst [new file with mode: 0755]
debian/rules [new file with mode: 0755]

diff --git a/README.CARNet b/README.CARNet
new file mode 100644 (file)
index 0000000..df3e0e6
--- /dev/null
@@ -0,0 +1,9 @@
+openssh-cn
++--------+
+
+Paket dodaje u sshd_config:
+
+ * ReverseMappingCheck yes
+ * PermitRootLogin no
+
+ -- Ivan 'ico' Rako <irako@srce.hr>  Thu, 20 Nov 2003 19:17:02 +0100
diff --git a/changelog.CARNet b/changelog.CARNet
new file mode 100644 (file)
index 0000000..0b29de9
--- /dev/null
@@ -0,0 +1,19 @@
+openssh-cn (2:4.3p2-1) carnet-etch; urgency=medium
+
+  * Prva verzija za Etch.
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Tue, 18 Sep 2007 16:04:41 +0200
+
+openssh-cn (2:3.8p1-2)
+
+  * nova inacica Debian paketa
+  * /usr/local/doc -> /usr/share/doc
+  * zakomentirana stara opcija ReverseMappingCheck
+
+ -- Ivan 'ico' Rako <irako@srce.hr>  Tue, 30 Mar 2004 01:21:39 +0200
+
+openssh-cn (2:3.6.1p2-11)
+
+  * inicijalna verzija paketa
+
+ -- Ivan 'ico' Rako <irako@srce.hr>  Thu, 20 Nov 2003 19:29:17 +0100
diff --git a/debian/changelog b/debian/changelog
new file mode 120000 (symlink)
index 0000000..dbf0845
--- /dev/null
@@ -0,0 +1 @@
+../changelog.CARNet
\ No newline at end of file
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..b8626c4
--- /dev/null
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..1e18992
--- /dev/null
@@ -0,0 +1,14 @@
+Source: openssh-cn
+Section: net
+Priority: optional
+Maintainer: Ivan Rako <Ivan.Rako@CARNet.hr>
+Build-Depends: debhelper (>= 4.0.0)
+Standards-Version: 3.6.1
+
+Package: openssh-cn
+Architecture: all
+Depends: carnet-tools-cn (>= 2.5), ssh (>= 2.0)
+Description: Secure shell client and server (transitional package)
+ This is a transitional package depending on both the OpenSSH client and
+ the OpenSSH server, which are now in separate packages. You may remove
+ it once the upgrade is complete and nothing depends on it.
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..d92e2d1
--- /dev/null
@@ -0,0 +1,2 @@
+README.CARNet
+changelog.CARNet
diff --git a/debian/postinst b/debian/postinst
new file mode 100755 (executable)
index 0000000..1e68c7e
--- /dev/null
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+set -e
+[ "$1" = "configure" ] || exit 0
+
+. /usr/share/carnet-tools/functions.sh
+
+if [ -f /etc/ssh/sshd_config ]; then
+  check_and_sed '^PermitRootLogin yes' \
+                's/PermitRootLogin yes/PermitRootLogin no/g' \
+               /etc/ssh/sshd_config || true
+
+  check_and_sed '^ReverseMappingCheck' \
+                's/^ReverseMappingCheck/#ReverseMappingCheck/g' \
+               /etc/ssh/sshd_config || true
+fi
+
+# restart
+if [ -x /usr/sbin/invoke-rc.d ]; then
+  [ -x /etc/init.d/ssh ] && invoke-rc.d ssh restart
+else
+  [ -x /etc/init.d/ssh ] && /etc/init.d/ssh restart
+fi
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..8d8c5ac
--- /dev/null
@@ -0,0 +1,86 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       # Add here commands to configure the package.
+
+       touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+
+       # Add here commands to compile the package.
+       # $(MAKE)
+
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+
+       # Add here commands to clean up after the build process.
+       # -$(MAKE) clean
+
+       dh_clean 
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k 
+       dh_installdirs
+
+       # Add here commands to install the package into debian/openssh-cn.
+       # $(MAKE) install DESTDIR=$(CURDIR)/debian/openssh-cn
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+#      dh_installchangelogs -k
+       dh_installdocs
+#      dh_installexamples
+       dh_install
+#      dh_installmenu
+#      dh_installdebconf       
+#      dh_installlogrotate
+#      dh_installemacsen
+#      dh_installpam
+#      dh_installmime
+#      dh_installinit
+#      dh_installcron
+#      dh_installinfo
+       dh_installman
+#      dh_link
+#      dh_strip
+#      dh_compress
+       dh_fixperms
+#      dh_perl
+#      dh_python
+#      dh_makeshlibs
+       dh_installdeb
+#      dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure