- #19996: popravljeni bugovi iz lintian reporta (Valentin Vidic)
[ossec-hids.git] / debian / rules
index 6150881..4e01349 100755 (executable)
@@ -44,7 +44,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        # ugly directory creation
@@ -94,7 +94,7 @@ install: build
        chmod 550 $(DESTDIR)/bin/*
        chmod 440 $(DESTDIR)/etc/ossec.conf
 
-    # fixups: no need for execute bits on files there
+       # fixups: no need for execute bits on files there
        find $(DESTDIR)/rules -type f -exec chmod ugo-x '{}' ';'
        find $(DESTDIR)/etc -type f -exec chmod ugo-x '{}' ';'
 
@@ -116,6 +116,10 @@ install: build
 
 # Build architecture-independent files here.
 binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs
@@ -139,13 +143,10 @@ binary-indep: build install
 #      dh_perl
 #      dh_python
        dh_installdeb
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install