- #19996: popravljeni bugovi iz lintian reporta (Valentin Vidic)
[ossec-hids.git] / debian / rules
index db885c7..4e01349 100755 (executable)
@@ -36,6 +36,7 @@ clean:
                $(SRCDIR)/analysisd/ossec-logtest \
                $(SRCDIR)/isbigendian \
                $(SRCDIR)/isbigendian.c \
+               $(SRCDIR)/analysisd/ossec-makelists
        rm -rf $(CURDIR)/bin
 
        dh_clean
@@ -43,7 +44,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        # ugly directory creation
@@ -93,7 +94,7 @@ install: build
        chmod 550 $(DESTDIR)/bin/*
        chmod 440 $(DESTDIR)/etc/ossec.conf
 
-    # fixups: no need for execute bits on files there
+       # fixups: no need for execute bits on files there
        find $(DESTDIR)/rules -type f -exec chmod ugo-x '{}' ';'
        find $(DESTDIR)/etc -type f -exec chmod ugo-x '{}' ';'
 
@@ -110,11 +111,15 @@ install: build
        # system ossec-init
        echo "DIRECTORY=\"/var/ossec\""      >  $(PKGDIR)/etc/ossec-init.conf
        echo "VERSION=\"`cat src/VERSION`\"" >> $(PKGDIR)/etc/ossec-init.conf
-       echo "DATE=\"$(date --utc -d "$(dpkg-parsechangelog | sed -ne 's/Date: //p')")\""       >> $(PKGDIR)/etc/ossec-init.conf
+       echo "DATE=\"$(shell date --utc -d "$(shell dpkg-parsechangelog | sed -ne 's/Date: //p')")\""   >> $(PKGDIR)/etc/ossec-init.conf
        echo "TYPE=\"local\""                >> $(PKGDIR)/etc/ossec-init.conf
 
 # Build architecture-independent files here.
 binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs
@@ -138,13 +143,10 @@ binary-indep: build install
 #      dh_perl
 #      dh_python
        dh_installdeb
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install