Inicijalna inacica paketa.
authorDragan Dosen <ddosen@ffzg.hr>
Thu, 28 Apr 2011 21:19:13 +0000 (23:19 +0200)
committerDragan Dosen <ddosen@ffzg.hr>
Thu, 28 Apr 2011 21:19:13 +0000 (23:19 +0200)
README.CARNet [new file with mode: 0644]
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/lintian-overrides [new file with mode: 0644]
debian/postinst [new file with mode: 0755]
debian/postrm [new file with mode: 0755]
debian/rules [new file with mode: 0755]

diff --git a/README.CARNet b/README.CARNet
new file mode 100644 (file)
index 0000000..7fb92a5
--- /dev/null
@@ -0,0 +1,8 @@
+php-apc-cn
+~~~~~~~~~~
+
+Ovaj paket je trenutno dummy, no u doglednoj buducnosti ce donositi
+postavke potrebne za normalno funkcioniranje pojedinih CARNet paketa.
+
+
+ -- Dragan Dosen <ddosen@ffzg.hr>  Thu, 28 Apr 2011 23:07:15 +0200
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..55282f1
--- /dev/null
@@ -0,0 +1,5 @@
+php-apc-cn (3.1.3p1+1) stable; urgency=low
+
+  * Inicijalna inacica paketa.
+
+ -- Dragan Dosen <ddosen@ffzg.hr>  Thu, 28 Apr 2011 23:07:15 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..7f8f011
--- /dev/null
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..11c2ad3
--- /dev/null
@@ -0,0 +1,20 @@
+Source: php-apc-cn
+Section: php
+Priority: optional
+Maintainer: Dragan Dosen <ddosen@ffzg.hr>
+Build-Depends: debhelper (>= 7)
+Standards-Version: 3.9.1
+
+Package: php-apc-cn
+Architecture: all
+Depends: php-apc (>= 3.1.3p1-2), ${misc:Depends}
+Description: APC (Alternative PHP Cache) module for PHP 5
+ Alternative PHP Cache
+ .
+ The Alternative PHP Cache, also known as APC, is a free, open, and robust
+ framework for caching and optimizing PHP intermediate code. APC is a fast
+ solution for caching PHP code locally, it is not distributed like MemcacheD,
+ but they can be used together for optimal caching.
+ .
+ This package brings CARNet-related configuration.
+Homepage: http://pecl.php.net/package/APC
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..5350ae7
--- /dev/null
@@ -0,0 +1,7 @@
+Copyright 2011 CARNet 
+
+You are free to distribute this software package under the terms of the
+GNU General Public License.
+
+On Debian systems, the complete text of the GNU General Public
+License can be found in the file /usr/share/common-licenses/GPL.
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..8f6e250
--- /dev/null
@@ -0,0 +1 @@
+README.CARNet
diff --git a/debian/lintian-overrides b/debian/lintian-overrides
new file mode 100644 (file)
index 0000000..5dc1352
--- /dev/null
@@ -0,0 +1 @@
+php-apc-cn: possibly-insecure-handling-of-tmp-files-in-maintainer-script
diff --git a/debian/postinst b/debian/postinst
new file mode 100755 (executable)
index 0000000..934e3f7
--- /dev/null
@@ -0,0 +1,66 @@
+#!/bin/sh
+# postinst script for proftpd-cn
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+#        * <postinst> `configure' <most-recently-configured-version>
+#        * <old-postinst> `abort-upgrade' <new version>
+#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+#          <new-version>
+#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+#          <failed-install-package> <version> `removing'
+#          <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+#
+
+case "$1" in
+    configure|reconfigure)
+      # continue below
+    ;;
+
+    *)
+        exit 0
+    ;;
+esac
+
+# Import CN toolsa
+. /usr/share/carnet-tools/functions.sh
+
+CONF=/etc/php5/conf.d/apc.ini
+
+if [ -e "$CONF" ]; then
+    echo "CN: Enabling APC tuneups"
+    cp -a "$CONF" "$CONF.$$"
+    cp-update --comment ';' php-apc-cn "$CONF.$$" <<EOF
+apc.enabled=1
+apc.shm_size=64
+apc.include_once_override=1
+apc.shm_segments=1
+apc.ttl=7200
+apc.user_ttl=7200
+apc.num_files_hint=1024
+apc.mmap_file_mask=/tmp/apc.XXXXXX
+apc.enable_cli=1
+apc.max_file_size=10M
+EOF
+    cp_mv "$CONF.$$" "$CONF"
+fi
+
+# reload Apache
+if apache2ctl configtest 2>/dev/null; then
+    echo "CN: Reloading Apache..."
+    invoke-rc.d apache2 force-reload || true
+else
+    echo "CN: Your Apache2 configuration is either broken or nonexistant"
+fi
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/postrm b/debian/postrm
new file mode 100755 (executable)
index 0000000..ef469c7
--- /dev/null
@@ -0,0 +1,52 @@
+#!/bin/sh
+# postrm script for monit-cn
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+#        * <postrm> `remove'
+#        * <postrm> `purge'
+#        * <old-postrm> `upgrade' <new-version>
+#        * <new-postrm> `failed-upgrade' <old-version>
+#        * <new-postrm> `abort-install'
+#        * <new-postrm> `abort-install' <old-version>
+#        * <new-postrm> `abort-upgrade' <old-version>
+#        * <disappearer's-postrm> `disappear' <r>overwrit>r> <new-version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+case "$1" in
+    purge)
+      # continue below
+    ;;
+
+    *)
+        exit 0
+    ;;
+esac
+
+# import CN-functions
+. /usr/share/carnet-tools/functions.sh
+
+CONF=/etc/php5/conf.d/apc.ini
+
+# remove us from inittab
+echo "CN: Removing APC tuneups"
+cp-update --comment ';' -r php-apc-cn "$CONF"
+
+# reload Apache
+if apache2ctl configtest 2>/dev/null; then
+    echo "CN: Reloading Apache..."
+    invoke-rc.d apache2 force-reload || true
+else
+    echo "CN: Your Apache2 configuration is either broken or nonexistant"
+fi
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..cbe925d
--- /dev/null
@@ -0,0 +1,3 @@
+#!/usr/bin/make -f
+%:
+       dh $@