Added a dependency on debconf (debian/control).
authorDragan Dosen <bane@nekkar.carnet.hr>
Wed, 2 Apr 2008 09:48:08 +0000 (11:48 +0200)
committerDragan Dosen <bane@nekkar.carnet.hr>
Wed, 2 Apr 2008 09:48:08 +0000 (11:48 +0200)
In debian/postinst, using 'printf' instead of 'echo -e'.

debian/control
debian/postinst

index c45e508..ac36990 100644 (file)
@@ -8,7 +8,7 @@ Standards-Version: 3.6.1
 
 Package: php4-cn
 Architecture: all
-Depends: libapache2-mod-php4, php4-cli, php4-mysql, carnet-tools-cn (>= 2.4)
+Depends: libapache2-mod-php4, php4-cli, php4-mysql, debconf, carnet-tools-cn (>= 2.4)
 Conflicts: php5-cn
 Description: server-side, HTML-embedded scripting language (CARNet configuration)
  This package is a meta-package that, when installed, guarantees that you
index 26a3e5f..6979c4e 100755 (executable)
@@ -139,7 +139,7 @@ for php4ext in $EXTENSIONS; do
 
                cp_echo "CN: Adding $php4ext extension to file $PHP4CONFD/$php4ext.ini"
                
-               echo -e "# configuration for php $php4ext_up module\nextension=$php4ext.so" >> "$INITMP"
+               printf "# configuration for php %s module\nextension=%s\n" "${php4ext_up}" "${php4ext}" >> "$INITMP"
                cp_mv "$INITMP" "$PHP4CONFD/$php4ext.ini"
                
                need_restart=1