Added a dependency on debconf (debian/control).
authorDragan Dosen <bane@nekkar.carnet.hr>
Wed, 2 Apr 2008 10:04:32 +0000 (12:04 +0200)
committerDragan Dosen <bane@nekkar.carnet.hr>
Wed, 2 Apr 2008 10:04:32 +0000 (12:04 +0200)
In debian/postinst, using 'printf' instead of 'echo -e'.

debian/control
debian/postinst

index de9a31f..fae7f90 100644 (file)
@@ -8,7 +8,7 @@ Standards-Version: 3.6.1
 
 Package: php5-cn
 Architecture: all
-Depends: libapache2-mod-php5, php5-cli, php5-mysql, carnet-tools-cn (>= 2.4)
+Depends: libapache2-mod-php5, php5-cli, php5-mysql, debconf, carnet-tools-cn (>= 2.4)
 Conflicts: php4-cn
 Description: server-side, HTML-embedded scripting language (CARNet configuration)
  This package is a meta-package that, when installed, guarantees that you
index f17140b..25b9804 100755 (executable)
@@ -139,7 +139,7 @@ for php5ext in $EXTENSIONS; do
 
                cp_echo "CN: Adding $php5ext extension to file $PHP5CONFD/$php5ext.ini"
                
-               echo -e "# configuration for php $php5ext_up module\nextension=$php5ext.so" >> "$INITMP"
+               printf "# configuration for php %s module\nextension=%s\n" "${php5ext_up}" "${php5ext}" >> "$INITMP"
                cp_mv "$INITMP" "$PHP5CONFD/$php5ext.ini"
                
                need_restart=1