r9:
authorIvan Rako <Ivan.Rako@CARNet.hr>
Tue, 30 Oct 2007 00:05:45 +0000 (00:05 +0000)
committerIvan Rako <Ivan.Rako@CARNet.hr>
Tue, 30 Oct 2007 00:05:45 +0000 (00:05 +0000)
debian/changelog
debian/control
debian/postinst
debian/postrm

index 551e9a6..d36b0a2 100644 (file)
@@ -1,6 +1,8 @@
-postfix-cn (2.3.8-1) carnet-etch; urgency=high
+postfix-cn (2.3.8-1) stable; urgency=high
 
   * Prva verzija za Etch
+  * Izbacen postgrey
+  * localhost.$mydomain u mydestination
 
  -- Ivan Rako <irako@srce.hr>  Mon, 22 Oct 2007 00:00:10 +0200
 
index 94c9e8c..9cf0815 100644 (file)
@@ -7,7 +7,7 @@ Standards-Version: 3.6.1
 
 Package: postfix-cn
 Architecture: all
-Depends: postfix, postfix-tls, carnet-tools-cn (>= 2.7), sasl2-bin, libsasl2-modules, postgrey, debconf, openssl
+Depends: postfix, postfix-tls, carnet-tools-cn (>= 2.7), sasl2-bin, libsasl2-modules, debconf, openssl
 Conflicts: sendmail-cn, amavisd-cn (<< 2:20030616p10-10), amavisd-new-milter, sendmail-base
 Suggests: amavisd-cn
 Description: A high-performance mail transport agent
index a0293f1..eab468e 100755 (executable)
@@ -81,11 +81,14 @@ postconf -e mynetworks="$mynetworks"
 
 # obrisati $mydomain, ako je upgrade sa starije verzije
 # te srediti mydestination
-if dpkg --compare-versions "$2" lt 2.1.5-8; then
+if dpkg --compare-versions "$2" lt 2.3.8-1; then
   mydestination="`postconf -h mydestination`"
   if echo $mydestination | grep -q ", \$mydomain"; then
     mydestination="`echo $mydestination | sed 's/, \$mydomain//g'`"
   fi
+  if echo $mydestination | grep -q "localhost.\$mydomain"; then
+    mydestination="$mydestination, localhost.\$mydomain"
+  fi
   postconf -e mydestination="$mydestination"
 fi
 
@@ -353,30 +356,6 @@ if [ -x /usr/share/postfix-cn/make-aliases-gecos.sh ]; then
   fi
 fi
 
-if dpkg --compare-versions "$2" lt 2.1.5-6 && \
-   [ -f /etc/postgrey/whitelist_clients ]; then
-  # dodaj CARNet MX u /etc/postgrey/whitelist_clients
-  cp-update postfix-cn /etc/postgrey/whitelist_clients < /usr/share/postfix-cn/carnet_whitelist_clients
-  restart_postgrey="yes"
-fi
-
-if [ -f /etc/default/postgrey ]; then
-  if ! grep -q "^POSTGREY_OPTS=.*--delay" /etc/default/postgrey; then
-    cp_check_and_sed 'POSTGREY_OPTS=' \
-                     's/^POSTGREY_OPTS="/POSTGREY_OPTS="--delay=58 /g' \
-                    /etc/default/postgrey || true
-  restart_postgrey="yes"
-  fi
-fi
-
-if [ "$restart_postgrey" = "yes" ]; then
-  if [ -x /usr/sbin/invoke-rc.d ]; then
-    [ -x /etc/init.d/postgrey ] && invoke-rc.d postgrey restart
-  else
-    [ -x /etc/init.d/postgrey ] && /etc/init.d/postgrey restart
-  fi
-fi
-
 # restart 
 if [ "$restart_postfix" = "yes" ]; then
   if [ -x /usr/sbin/invoke-rc.d ]; then
index 84cf490..b6dcb1f 100755 (executable)
@@ -8,5 +8,3 @@ set -e
 . /usr/share/debconf/confmodule
 
 db_purge || true
-
-cp-update -r postfix-cn /etc/postgrey/whitelist_clients