r13: origin
authorIvan Rako <Ivan.Rako@CARNet.hr>
Thu, 27 Dec 2007 13:00:05 +0000 (13:00 +0000)
committerIvan Rako <Ivan.Rako@CARNet.hr>
Thu, 27 Dec 2007 13:00:05 +0000 (13:00 +0000)
debian/changelog
debian/postinst

index d36b0a2..4037e6b 100644 (file)
@@ -1,3 +1,9 @@
+postfix-cn (2.3.8-2) stable; urgency=medium
+
+  * Sitne ispravke u postinstu
+
+ -- Ivan Rako <irako@srce.hr>  Thu, 27 Dec 2007 13:45:34 +0100
 postfix-cn (2.3.8-1) stable; urgency=high
 
   * Prva verzija za Etch
index 2c4826f..89bb37e 100755 (executable)
@@ -81,7 +81,7 @@ postconf -e mynetworks="$mynetworks"
 
 # obrisati $mydomain, ako je upgrade sa starije verzije
 # te srediti mydestination
-if dpkg --compare-versions "$2" lt 2.3.8-1; then
+if dpkg --compare-versions "$2" lt 2.3.8-2; then
   mydestination="`postconf -h mydestination`"
   if echo $mydestination | grep -q ", \$mydomain"; then
     mydestination="`echo $mydestination | sed 's/, \$mydomain//g'`"
@@ -89,6 +89,9 @@ if dpkg --compare-versions "$2" lt 2.3.8-1; then
   if ! echo $mydestination | grep -q "localhost.\$mydomain"; then
     mydestination="$mydestination, localhost.\$mydomain"
   fi
+  if ! echo $mydestination | grep -q "\$myhostname"; then
+    mydestination="\$myhostname, $mydestination"
+  fi
   postconf -e mydestination="$mydestination"
 fi