- izracun i postavljanje trusted_networks
authorDinko Korunic <kreator@carnet.hr>
Sun, 1 Mar 2009 20:30:10 +0000 (21:30 +0100)
committerDinko Korunic <kreator@carnet.hr>
Sun, 1 Mar 2009 20:30:10 +0000 (21:30 +0100)
debian/changelog
debian/postinst
local.cf

index bdd4291..aa2652a 100644 (file)
@@ -1,3 +1,9 @@
+spamassassin-cn (2:3.2.5-4) stable; urgency=low
+
+  * izracun i postavljanje trusted_networks
+
+ -- Dinko Korunic <kreator@carnet.hr>  Sun,  1 Mar 2009 20:03:57 +0100
+
 spamassassin-cn (2:3.2.5-3) stable; urgency=low
 
   * dva nova phishing potpisa za phishing napade ucestale prema CARNet
index c546d27..06d468f 100755 (executable)
@@ -117,7 +117,7 @@ if [ -f $examdir/local.cf ]; then
 
     # old enough
     if [ -s $confdir/local.cf ] &&
-            dpkg --compare-versions "$2" lt "2:3.0.3-3"; then
+            dpkg --compare-versions "$2" lt "2:3.2.5-4"; then
         echo "CN: Backing up old version of $confdir/local.cf in /var/backups"
         cp_backup_conffile $confdir/local.cf
         rm -f $confdir/local.cf
@@ -199,6 +199,21 @@ if [ -f $examdir/local.cf ]; then
             mv -f $confdir/local.cf.$$.$$ $confdir/local.cf.$$
     rm -f $confdir/local.cf.$$.$$
 
+    # calculate trusted networks
+    cp_get_netaddr || true
+    netaddr="$RET"
+    trusted_networks=$(awk '/^trusted_networks/ { print $2 }' \
+        $confdir/local.cf.$$)
+    for i in "127.0.0.0/8" "$netaddr"; do
+        if ! echo "$trusted_networks" | grep -q "$i"; then
+            trusted_networks="$trusted_networks $i"
+        fi
+    done
+    cp_check_and_sed "^trusted_networks " \
+        "s#^trusted_networks .*#trusted_networks $trusted_networks#g" \
+        $confdir/local.cf.$$ || true
+    echo "CN: Activated $trusted_networks as trusted networks"
+
     # different than template
     if ! cmp -s $confdir/local.cf.$$ $confdir/local.cf; then
         # backup if not zero size
index c8e8357..631141f 100644 (file)
--- a/local.cf
+++ b/local.cf
@@ -69,3 +69,6 @@ allow_user_rules 0
 
 # Specific whitelisting
 whitelist_from pomoc@iskon.hr
+
+# Trusted networks
+trusted_networks 127.0.0.0/8