* backport korisnih promjena iz CARNet Lenny paketa
authorDinko Korunic <kreator@carnet.hr>
Wed, 7 Oct 2009 16:42:26 +0000 (18:42 +0200)
committerDinko Korunic <kreator@carnet.hr>
Wed, 7 Oct 2009 16:42:26 +0000 (18:42 +0200)
debian/changelog
debian/postinst

index 505ff92..2baad65 100644 (file)
@@ -1,3 +1,9 @@
+spamassassin-cn (2:3.2.5-7) stable; urgency=low
+
+  * backport korisnih promjena iz CARNet Lenny paketa
+
+ -- Dinko Korunic <kreator@carnet.hr>  Wed,  7 Oct 2009 18:38:23 +0200
+
 spamassassin-cn (2:3.2.5-6) stable; urgency=low
 
   * spajanje IP klasa iz mynetworks Postfix konfiguracije u trusted_networks
index e931e54..ff854eb 100755 (executable)
@@ -204,7 +204,7 @@ if [ -f $examdir/local.cf ]; then
     netaddr="$RET"
     # ... get already configured trusted networks
     trusted_networks=$(awk '/^trusted_networks/ { print $2 }' \
-        $confdir/local.cf.$$)
+        $confdir/local.cf.$$ | sed -e 's/,/ /g')
     # ... merge with local networks configured on eth interfaces
     for i in $netaddr; do
         if ! echo "$trusted_networks" | grep -q "$i"; then
@@ -213,7 +213,7 @@ if [ -f $examdir/local.cf ]; then
     done
     # ... merge with Postfix ranges
     if [ -x /usr/sbin/postconf ]; then
-        for i in $(postconf -h mynetworks); do
+        for i in $(postconf -h mynetworks | sed -e 's/,/ /g'); do
             if ! echo "$trusted_networks" | grep -q "$i"; then
                 trusted_networks="$trusted_networks $i"
             fi
@@ -221,10 +221,12 @@ if [ -f $examdir/local.cf ]; then
     fi
     # ... strip 127/8 range
     for i in $trusted_networks; do
-        if ! echo "$i" | grep -q "127.0.0.0/8"; then
+        if ! echo "$i" | egrep -q \
+            "127.0.0.0/8|\[::1\]/128|\[::ffff:127.0.0.0\]/104"; then
             trusted_networks_clean="$trusted_networks_clean $i"
         fi
     done
+    # ... strip left and right blanks from final string
     trusted_networks_clean=$(echo "$trusted_networks_clean" \
         |  sed 's/^[ \t]*//;s/[ \t]*$//')
     # ... and replace if non-zero