Prilagodba paketa za novi paket squirrelmail-change-pass.
[squirrelmail-change-pass-cn.git] / debian / rules
index b7c199b..c22b759 100755 (executable)
@@ -1,63 +1,34 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
-#export DH_VERBOSE=1
+PACKAGE = $(shell dh_listpackages)
+TMP     = $(CURDIR)/debian/$(PACKAGE)
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       touch configure-stamp
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       dh_clean 
+       dh_clean
+       rm -f install-stamp
 
-install: build
+install: build install-stamp
+install-stamp:
        dh_testdir
        dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-binary-indep: build install
+       dh_clean
+       touch install-stamp
 
 binary-arch: build install
+
+binary-indep: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
        dh_installdocs
-       dh_install -X.svn -Xchange_pass/doc -Xchange_pass/config_example.php -Xchange_pass/README
-       dh_installexamples
-#      dh_install
-#      dh_installmenu
-       dh_installdebconf
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
+       dh_installchangelogs
        dh_link
-#      dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_python
-#      dh_makeshlibs
+       dh_installdebconf
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
@@ -65,4 +36,3 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure