- maknut query-source kao direktiva viska
authorDinko Korunic <kreator@carnet.hr>
Sun, 1 Mar 2009 22:03:37 +0000 (23:03 +0100)
committerDinko Korunic <kreator@carnet.hr>
Sun, 1 Mar 2009 22:03:37 +0000 (23:03 +0100)
debian/changelog
debian/postinst

index 818e7fe..4fc640a 100644 (file)
@@ -1,3 +1,9 @@
+bind9-cn (2:9.2.4-3) stable; urgency=low
+
+  * maknut query-source kao direktiva viska
+
+ -- Dinko Korunic <kreator@carnet.hr>  Sun,  1 Mar 2009 22:51:26 +0100
+
 bind9-cn (2:9.2.4-2) stable; urgency=low
 
   * korekcija postinst, pretrazi lame-servers logging i u named.conf i u
index 49b83ca..4b0b4c8 100755 (executable)
@@ -73,7 +73,6 @@ acl "trusted" {
 
 options {
     directory "/etc/bind";
-    query-source address * port 53;
     auth-nxdomain no;
     allow-transfer { xfer; };
     allow-recursion { trusted; };
@@ -176,6 +175,16 @@ EOF
   rndc reload || echo "CN: Reload didn't work, please check manually"
 fi
 
+if [ -e /etc/bind/named.conf.options ] && \
+    fgrep -q 'query-source address * port 53' \
+        /etc/bind/named.conf.options; then
+        fgrep -v 'query-source address * port 53' \
+            /etc/bind/named.conf.options > /etc/bind/named.conf.options.$$
+    cp_mv /etc/bind/named.conf.options.$$ /etc/bind/named.conf.options
+    echo "CN: Removing obsolete query-source directive"
+    rndc reload || echo "CN: Reload didn't work, please check manually"
+fi
+
 # dh_installdeb will replace this with shell code automatically
 # generated by other debhelper scripts.