Cleanup packaging
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Fri, 22 Sep 2017 13:28:36 +0000 (15:28 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Fri, 22 Sep 2017 13:28:36 +0000 (15:28 +0200)
debian/clean [new file with mode: 0644]
debian/compat
debian/control
debian/rules
debian/source/format [new file with mode: 0644]

diff --git a/debian/clean b/debian/clean
new file mode 100644 (file)
index 0000000..c5f5e47
--- /dev/null
@@ -0,0 +1,5 @@
+doc/carnet-upgrade.txt
+doc/carnet-upgrade.html
+doc/carnet-upgrade.pdf
+doc/carnet-upgrade.tpt
+doc/carnet-upgrade.sgml
index 7f8f011..ec63514 100644 (file)
@@ -1 +1 @@
-7
+9
index e162a06..c188621 100644 (file)
@@ -3,9 +3,9 @@ Section: admin
 Priority: extra
 Maintainer: Grupa za izradu paketa <paketi@carnet.hr>
 Uploaders: Valentin Vidic <Valentin.Vidic@CARNet.hr>, Zeljko Boros <Zeljko.Boros@carnet.hr>
-Build-Depends: debhelper (>= 7), po-debconf, debiandoc-sgml, texlive,
+Build-Depends: debhelper (>= 9), po-debconf, debiandoc-sgml, texlive,
  texlive-latex-extra, texlive-lang-european, ghostscript
-Standards-Version: 3.9.6
+Standards-Version: 3.9.8
 
 Package: carnet-upgrade
 Architecture: all
index e827a56..b94f454 100755 (executable)
@@ -1,23 +1,14 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+%:
+       dh $@
 
 PKG_VERSION = $(shell dpkg-parsechangelog|sed -n 's/^Version: \(.*:\|\)//p')
 
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-
-build-stamp: doc/carnet-upgrade-src.sgml
-       dh_testdir
-
+override_dh_auto_build:
        # Update package version in documentation
        sed -e 's/%PKG_VERSION%/$(PKG_VERSION)/g' doc/carnet-upgrade-src.sgml \
                > doc/carnet-upgrade.sgml
@@ -36,65 +27,11 @@ build-stamp: doc/carnet-upgrade-src.sgml
        (cd doc; debiandoc2pdf -l hr_HR.UTF-8 carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt
 
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       # Clean up after the build process.
-       rm -rf doc/carnet-upgrade.{txt,html,pdf,tpt,sgml}
-
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean
-       dh_installdirs
-
-       # Install the package.
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
+override_dh_install:
        dh_install
+
        # Update package version in source
        sed -i -e 's/%PKG_VERSION%/$(PKG_VERSION)/g' \
                debian/carnet-upgrade/usr/share/carnet-upgrade/cn-upgrade
        # Remove documentation template
        rm -f debian/carnet-upgrade/usr/share/doc/carnet-upgrade/carnet-upgrade-src.sgml
-#      dh_installmenu
-       dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do here.
-
-binary: binary-indep
-.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/source/format b/debian/source/format
new file mode 100644 (file)
index 0000000..89ae9db
--- /dev/null
@@ -0,0 +1 @@
+3.0 (native)